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Introduction

XnViewMP is an exceptionally versatile photo organizer and viewer that can satisfy the most
demanding of photographers. It provides many features normally found only in paid-for programs,
including sophisticated tools to classify and sort photos, batch operations for processing multiple
images, the ability to edit metadata, as well as support for over 500 image formats, and exporting
to over 70 file formats. It also offers a range of photo editing tools, which while not in the same
league as those offered by Gimp or Photoshop, are more than enough for most people. And, most
importantly for the occasional user, it is easy to use.

In this guide, I’ll begin by showing you how to set up XnViewMP in the simplest possible way, so
that you can readily master the basics. Then I’ll explain how to move on to more advanced options,
should you wish to explore these.

The ‘MP’ in XnViewMP stands for ‘Multi-Platform’, meaning it will run on all major computer
platforms - Windows, macOS, and Linux, in both 32-bit and 64-bit versions. (This is in contrast to
the original ‘Classic’ XnView, which was restricted to Windows.) I am running XnViewMP on
Linux (Ubuntu), and the screenshots in this guide are from that system. To download the latest
version of XnViewMP, go to https://www.xnview.com/en/xnviewmp/
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Browse Mode

XnViewMP, when you run it, opens in Browse mode. The figure above shows how this mode
looks on my (Linux) computer.

At the top is a menu bar together with a couple of toolbars: these offer a variety of options and
tools for organizing your photos. Occupying the main part of the screen below these are three
panels:
● The large Thumbnail panel on the right, showing the contents of the selected folder. Select a

thumbnail by clicking it, or multiple thumbnails by holding down Ctrl while clicking, or a
range of thumbnails using Shift+Click.

● The Tree panel at the top left, showing the folder tree. Clicking on a folder here will open
thumbnails of its contents in the Thumbnail panel.

● The Preview panel at the bottom left, showing a preview of the selected photo.

The Tree panel and the Preview panel can show a lot more information than their names imply, but
let’s keep things simple for now.

When you open XnViewMP for the first time after installing it, you will be
presented with a more complex layout showing much more information. For a
beginner so much information can be confusing, but fortunately it’s easy to set
up the simpler layout shown above. Before changing anything, however, I
suggest you save this initial layout should you wish to return to it later.

To save this initial layout:

1. Locate the Layout button on the main (Browse) toolbar at the top and click the down-arrow
at its right.
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2. On the Layout menu that appears, choose Save Layout A (see the figure).

If you do decide to return to this layout later, simply choose Restore Layout A from the same
menu.

Now to make Browse mode on your computer look like
the earlier figure:

● Open the View menu (on the menu bar at the top
of the screen), choose Layout, then Layout 3 - see
opposite.

From now on I’ll write such a sequence of steps thus:
View menu > Layout > Layout 3.

Now you can adjust the sizes of the panels by dragging on their borders, and you can simplify
things further by hiding the categorizing and filtering options.
(These are extremely useful for more experienced users, but let’s
stick to the basics for now.) To hide these:

● Right-click on the border between the two left-hand panels or
on the menu bar and untick the ‘Categories’ options, as shown
in the figure.

Finally, you can reduce the amount of information shown in the Thumbnail panel as follows:

● Click the down-arrow to the right of the ‘View As’ button on the
thumbnails toolbar (at the top of the screen, towards the right), and
from the menu that appears choose Thumbnails + Filenames.

When you’re happy with all the adjustments you’ve made, save your
layout:

● Click the arrow to the right of the Layout button on the Browse toolbar, and choose Save
Layout B.

Another adjustment you can make, which isn’t saved with your layout but which is restored when
you start another session, is to the size of the thumbnails:

● Change the thumbnail size by dragging the slider at the right of the
Thumbnail toolbar. Also try the effect of clicking the button at the
right of the slider bar.

One of the Tree panel options is to show Favorites, i.e. folders that you frequently use and wish to
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access quickly. To set a folder as a favorite, navigate to it in the Tree panel and click the star
button on the Thumbnail toolbar (to the right of the box showing the currently-selected folder).

Also if you click the down-arrow to the left of this star (i.e. alongside the box showing the name
of the selected folder), a list of your recently-opened folders will appear - invaluable if you wish to
return quickly to one of them.

If you wish to delve further into layouts, you can
try detaching one of the left panels and dragging
it around - press the □ button at the top right of
the panel to do this. If you place it on top of the
other panel you will merge the two into a single
panel, creating the even simpler layout shown in
the figure here. (You may find it a bit fiddly to
achieve this, but if you mess things up you can
always restore your saved Layout B!) If you like
this really simple layout, remember to save it (as
Layout C).

Image View Mode

To view a thumbnail’s image, double-click it, or simply press Enter if the thumbnail is already
selected (or click the Open button at the left of the toolbar). You have opened a separate tab called
View mode - see the figure above. Look at the top of this figure: there are several tabs open, each
holding a different image, and each is instantly accessible simply by clicking its tab. (It’s a bit like
when you run a web browser with different web pages in different tabs. And, like a web browser,
you can close a tab by clicking the ‘x’ button at its right.)
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These images may not necessarily come from the same folder. Often you will want to deal with
images from several folders: having selected one, you can switch folders in Thumbnail view and
select another (or go to File > Open in View mode and navigate to the photo you want in the Open
Image dialog box).

View mode has its own menu bar, offering a different selection of tools and options from the
Browser mode menu bar, and its own toolbar. Many of the tools and options available here are to
do with editing and manipulating the selected photo, and I’ll deal with the tools and options that
are to do with editing and enhancing photos in the next section.

Here, you should note the following:

● The Browse button at the left of the toolbar - this takes you to the folder containing the
selected image, and will display thumbnails of the photos in that folder. So if your selected
images come from different folders, then each tab would lead, via the Browse button, to a
different folder with a different set of thumbnails.

● The left-arrow and right-arrow buttons at the centre of the toolbar - clicking these will cycle
through the images in the relevant folder (i.e. images whose thumbnails are displayed in
Browse mode). Pressing the left or right arrow keys will do the same.

● The three zoom buttons, to the left of centre of the toolbar - invaluable if you need to work on
a photo in greater (or less) detail. The left (+) button increases the zoom, the right (-)
decreases, and the centre button sets the zoom to full-size 100%). The + and - buttons are
duplicated at the right of the status bar at the bottom of the screen, and here you can also see
the percentage value of the zoom. Note that if the zoomed photo is so large
you can only see part of it in the viewer, a reduced-size image is shown just
above the status bar at the right, with a red rectangle marking the visible
area. By dragging this rectangle with the mouse you can move the zoomed
photo around in the viewer. To instantly zoom/unzoom the image so that it
exactly fills the viewer, press the slash key /.

The Photo Editing Tools

XnViewMP offers a range of editing tools in View mode, including resizing, rotating, colorizing,
lightening/darkening, red-eye correction, and inserting drawings and text on the image. These
tools are found mainly in the Image menu and on the toolbar. It is beyond the scope of this
introductory guide to describe all these, but if you have used similar tools in other photo software
you should soon get the hang of things. You can play around with the many options here to your
heart’s content, as nothing you do is permanent until you actually save the image. I would
however draw your attention to the following:

● You can mark out a selection area on a photo by simply dragging over it with the mouse. You
can then reposition the selection by dragging it around with the mouse, and you can resize it



6

by dragging its edges. Alternatively you can open the Image menu and use the selection
options shown there: these allow you to set the selection to a definite size or ratio (e.g. A4, or
4:3, or 16:9). When you’ve finished adjusting your selection, you can e.g. crop it by clicking
the Crop tool (towards the left of the toolbar), or apply Red-Eye correction to it (from the
Image menu), or apply Spotlight effects (Image menu).

● Watch out for the ‘Apply to image’ checkbox in some dialog boxes. This has to be ticked to
apply your adjustments to the photo.

● The rotate tool (for straightening an image) provides grid lines to help
align the photo, as well as automatic cropping of the final result. You
will find this in the Image menu (Image > Rotate > Rotate...).

● There are a number of drawing tools (at Image > Draw..., or click the Draw button towards
the right of the View mode toolbar), including one to add some text to a photo. The figure
below shows these - note the buttons to zoom and unzoom the image, and to undo and redo
your changes. Note too the two overlapping boxes at the left, showing the foreground and
background colours - you may wish to change these before
applying one of the drawing tools. To do so, click on one of
the boxes, then select a colour from the dialog box, or use
the colour of selected point on the image.

● After selecting a drawing tool (by clicking its button), you need to drag over the image to
apply it. In the case of text, after typing it in the text box you need to click on the image at the
point where you want it to appear, then, while your text is still enclosed in a dotted red border,
you can move it around with the mouse, alter its size, add outlining and shadow effects, and
even change the text. Click OK when you’ve finished with all the tools to apply your efforts
to the image.

● To sharpen/blur a photo, as well many other effects, go to Image > Filter...

● To change the colours or adjust the brightness of a photo, go to Image > Adjust.

Finally, note that nothing you do in the way of editing an image is permanent until you actually
save the result (using the Save As tool at the left of the toolbar). If you quit
without saving, your changes are lost and the photo reverts to its original
state.

Context Menus and Hotkeys

These provide shortcuts to many XnViewMP features. If you right-click on
any screen element - an image, a toolbar, a panel - a context-menu listing
actions relevant to that element will appear. The figure to the right shows the
context menu that appears when you right-click on a thumbnail (in Browse
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mode). All the options on a context menu can be reached via the ordinary menus, but it can take a
while to search them out.

You will also notice that an alternative way of reaching many menu options is by pressing a
hotkey, i.e. a key combination such as Ctrl+I. For experienced users, this is a very fast way of
getting to frequently-used features.

Why not take a short break and try right-clicking different elements in both Browse and View
modes and examining the context menus that appear, including trying some of the menu items?
Note too that there are further context menus in some dialog boxes, such as the Save As dialog
box - have a look at these. Note in particular the Show all files (recursive) option, available when
you right-click a folder in the Tree panel. This will open thumbnails of all images in the folder and
all its subfolders.

Settings

Settings, accessed by clicking the gear button at the right of the toolbar (in either Browse mode or
View mode), allows you to customize a multitude of features in XnViewMP. It is impossible to
cover the many possibilities here, but I will draw
your attention to the following.

If you select Interface (from the menu at the left of
the Settings dialog box), then the Toolbar tab, you
will see that you can modify the toolbar by adding or
removing items, or by reordering items (by selecting
an item then clicking one of the arrow buttons in the
middle). Notice the Mode button towards the top left
- this allows you to select either the Browse mode
toolbar or the View mode toolbar.

The Shortcuts tab (next to the Toolbar tab) shows
the default keyboard shortcuts (hotkeys) that have
been set up for a number of tasks - see the figure.
As you can see from the top item (for example),
pressing the * key in View mode, will show the
image full-size (100%). Another hotkey is Ctrl+A,
which selects all thumbnails. You can if you wish
set up further hotkeys of your own at this tab.

It’s worth spending a few minutes examining every
tab under every option in Settings. It’ll make you aware of XnViewMP’s many features and
customization possibilities - there are far more than I can possibly cover here!
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File Operations

Nothing exemplifies XnViewMP’s versatility more than these. Besides the essential file operations
(Open, Save, Save As, and Export), XnViewMP allows you carry out file-handling tasks normally
associated with a file manager, such as renaming, copying, moving and deleting folders and files,
and creating new folders. And most of these operations can be accessed in a variety of ways: via
the menu system, the toolbars, context menus, or via hotkeys - the choice is yours. If you
frequently use an operation which is not available e.g. on a toolbar (Save being one example), you
can easily add it - go to Settings > Interface > Toolbar, as explained in the last section. Add to this
the fact that XnViewMP can handle an astonishing 500 different image formats and 70 different
file formats, and you can see it really stands out from the crowd.

You might wonder why you might want to use XnViewMP rather than a file manager to carry out
file operations such as copying, moving, or renaming. The reason is that XnViewMP will update
its database when it performs those operations, meaning that any categories that you assign to your
photos (see below) will be copied or moved as well.

XnViewMP’s file operations are fairly self-explanatory, so I’ll restrict myself to the essentials.

Open:You can open folders in Browse mode either via the Tree panel, or via the folder name box
at the left of the thumbnail toolbar, or by choosing File > Open... Note that in View mode, File >
Open... allows you to navigate through the file system to open an image directly in that mode,
bypassing Browse mode. (If you now click the Browse button at the left of the View mode toolbar,
you will open the contents of the folder containing that image in Browse mode, replacing the
previously-selected Browse mode folder.)

Save:Accessed from the File menu in View mode or by pressing Ctrl+S. If you modify a photo,
this option will overwrite the original file on the disk.

Save As:Accessed from the File menu in View mode, or by pressing Ctrl+Shift+S, or by clicking
the Save As toolbar button. This allows you to save a modified image under a different filename,
or in a different file format (e.g. PNG instead of JPG, to give just two out of 70 possibilities).

Export:Accessed from the File menu in View mode or the toolbar in Browse mode, or by
pressing Ctrl+Alt+S. This allows you not only to change the filename and file type but to remove
all metadata and to reduce the quality (to reduce the file size), as well as other changes.

Other file operations: Renaming, moving, copying, deleting and more can be accessed from the
File menu in View mode, or by the hotkeys shown there, and from the context menu in the
Thumbnail panel and Tree panel (obtained by right-clicking in these panels), and from the
Thumbnail panel toolbar. To copy a folder, for example, you must right-click its thumbnail in the
Thumbnail panel (having selected its containing folder in the Tree panel), then choose the Copy
option from the context menu.
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Batch operations: You can select multiple thumbnails by holding down the Ctrl key while
clicking. You can then apply most of the file operations listed above to the selection. You can even
rename them all in a single operation by choosing Batch rename... from the Tools menu (or
clicking the Rename button on the Thumbnail toolbar), then entering a new name in the Name
template field of the dialog box that appears. XnViewMP will apply that name to each slide, plus a
sequential number.

You can also convert all the files in the selection to a different file format by choosing Batch
convert... at the Tools menu. There are many options here, and a description of them is beyond the
scope of this beginners’ guide.

Note that you can’t export a batch - you have to export singly.

Screen Capture

You can capture the entire screen, or part of a screen, using this
tool. It works not only within XnViewMP itself but also in other
applications, provided XnViewMP is running in the background.
The images in this guide were obtained using this tool, which I
find is nicer to use than similar tools provided by other software.

If you click the Capture tool (at the centre of the Browse mode
toolbar, or right of centre on the View mode toolbar) a dialog box
like that shown here appears. The default hotkey to activate the tool is F1, but I prefer Shift+F1 as
this is less likely to conflict with the function key bindings that another application might use.
When you press the hotkey, the desktop, or a selected portion of it, is captured and displayed in
View mode. You can then if you wish edit the result then save it for inserting into a document such
as this.

Cataloging, Filtering, and Sorting

XnViewMP excels at this. You can categorize your photos by subject
(Family, Landscapes, Flowers, etc, plus categories of your own
choosing), you can rate photos by their quality (Excellent, Good, etc)
as well as by a further range of classifications such as Important,
Work, Personal, To Do. Having cataloged your photos, you can then
filter them, so that, for example, all your photos of flowers stored on
your computer in various folders appear together in the Thumbnail
panel. And here you can sort the order in which they appear, by name
date, folder, or whatever.

At this point you may wish to restore two items that were turned off at
the Tree and Preview panels at the beginning of this guide, namely
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Categories Filter and Categories. You can do this by right-clicking on the top border of the
Preview panel and selecting them from the context menu, or simply by reselecting Layout 3 from
the View menu (View > Layout > Layout 3). Categories and Categories Filter should now appear
as tab options at the left of the screen, at the Tree or Preview panels.

You can now select a batch of e.g. family photos in the Thumbnail pane, then, if you select the
Category tab, you can instantly mark them all as ‘Family’ by clicking that category in the
Categories panel. You can also select a batch of thumbnails that you wish to rate as ‘Excellent’, or
‘Important’, or whatever - in this case you have to click the arrow to the right of the Rating and
Colour Label button on Browse mode toolbar and choose from the list that appears.

Note that you can add further categories of your own own by right-clicking in the
Categories panel and selecting the appropriate option from the context menu that
appears (see the figure). You can also change the Colour Labels from ‘Important’
etc to labels of your own choosing. To do this, go to Settings > Metadata >
Labels.

Having classified your photos in this way, you can filter them (from all folders on your computer)
by category, rating, or label, or by a combination of these. To do so, make sure the Categories
Filter tab is selected (at the left of the Tree panel), then click on the required item (Rating, Colour
Label, or Category). You can select multiple items here by holding down Ctrl while clicking - this
has the effect of ANDing the items - i.e. the resulting thumbnails will have all the selected
attributes.

For a more versatile search, allowing you to use
OR as well as AND, and also specifying e.g. the
search folder, go to Tools > Search... (or press
Ctrl+F, or click the Search button on the toolbar).
The Search dialog box is shown alongside.

You can also filter thumbnails within a selected folder. To this, click the down arrow to the right of
the Filter by button on the Thumbnails toolbar. This allows you to e.g. show just images in the
Thumbnail pane, or just those that are labelled ‘To do’.

Finally, I should draw your attention to the sorting facility available in the Thumbnail panel. Click
the small arrow to the right of the Sort by button on the Thumbnail toolbar, and choose your
desired sort criterion from the list.

Note that categorization data is not stored with the photos but in a separate database file.

Tagging

This provides a simple way of marking photos across multiple folders
that you wish to select for some further operation (such as bringing
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them together by moving them to a single new folder). To tag a photo, or a group of selected
photos, right-click on the selection and from the context menu choose Tag > Tag current (or press
Ctrl+T).

To show all tagged thumbnails from all folders, choose Show tagged files from this dialog box (or
press Shift+T). They will all appear in the Thumbnail panel. You can now sort them e.g. by Name
or Folder or Date (using the Sort button on the Thumbnail toolbar), display them as a slideshow
(see next section), or select them all and use the context menu to e.g. move them all to a new
folder. To return to showing all images, click on the Filter button on the Thumbnail toolbar and
choose ‘All’.

To untag all tagged thumbnails in the selected folder, choose Untag all from this dialog box. To
untag all tagged thumbnails across all folders, choose Clear all tags.

Slideshow

XnViewMP offers a basic slideshow facility, just a single ‘Quick Slideshow’ button to the right of
centre on the View mode toolbar. This will run through the images from the Thumbnail panel in
turn, beginning with the image that’s open in View mode. Note the following:

● To show just a some of the images, select them in the Thumbnail panel (by holding down Ctrl
while clicking on them), press Enter to show the first in View mode, then click the Quick
Slideshow button.

● To show a selection of images from several folders, tag them first
as described above, then press Shift+T to assemble them in
Thumbnail view, then sort as required, then open the first image
in View mode and click the Quick Slideshow button.

● To change the speed of the slideshow, go to Settings > View > Misc > Quick Slideshow.

Metadata

This is data about a photo, stored as part of the photo file. It includes
data about the camera, the exposure, the date of the photo, and much
else besides (see the figure). You can view this data by clicking on
Info at the Preview panel (in Browse mode), then navigating through
the various tabs. The use of metadata is too big and complex a
subject to cover in this beginner’s guide, but I will briefly explain the
process of adding captions to photos (part of the IPTC-IIM metadata),
and how to display those captions in Browse view.

To edit metadata, you must be in Browse mode. Select a photo, then choose Tools > Metadata >
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Edit IPTC/XMP... (Alternatively, simply press
Ctrl+I.) As you can see from the dialog box
that appears, one of the items of information
that you can add as metadata is a caption. You
can then display those captions below the
photos in the Thumbnail panel.

You can choose what items of metadata to
display with thumbnails in Settings. Go to
Settings > Thumbnails > Labels, where you
can remove items you don’t want from the right-hand pane and add items you do want (such as
Caption) from the left-hand pane. For example, you might decide to include just the Filename and
the Caption in the right-hand pane. Click OK when you’ve finished.

To display your chosen metadata below the thumbnails, click the down-arrow to the right of the
‘View As’ button on the thumbnails toolbar, and from the menu that appears choose Thumbnails +
Labels.

I’ve briefly covered adding metadata to individual photos. However, XnViewMP makes it easy to
add metadata to batches of photos, and there is a YouTube tutorial on this at
https://www.youtube.com/watch?v=UhttWmfLcY8.

Thumbnail Cache Maintenance

Sometimes an error may creep into the thumbnail cache, so that some images in a folder have the
wrong thumbnail picture associated with them. You can fix this at Settings > Catalog > Catalog,
where you can delete the thumbnail cache for a selected folder, or for all folders. Deleting the
cache occasionally may also speed up access to your photos. XnViewMP will automatically
rebuild the thumbnails when you select that folder in the future.

Note that when you delete thumbnails, you will also delete any category settings that you may
have assigned to them. You can get round this by
only deleting those thumbnails to which categories
have not been assigned: when asked Do you want to
remove entries assigned to a category? choose ‘No’.

And there’s more...

There’s much more to explore than I’ve been able to cover in this introductory guide. For example,
you can create collages, mosaics, contact sheets and more at the Create menu (in Browse mode);
there are many range of photo editing and enhancement tools on the in View mode that I’ve only
briefly mentioned or ignored; and much else besides.
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One example is Spotlight (on the Image menu in View mode). This allows you to emphasize a
selected area of an image by e.g. brightening it relative to the rest. The best way to find out more
about this is to simply try it out and examine its various options.

There is a fair amount of online help available for XnView Classic, and much of this is applicable
to XnViewMP, although the interface and options are somewhat different. You will find this at:

https://www.xnview.com/wiki/index.php/XnView_(Windows)_User_Guide
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