From XnView Wiki

Ghostscript is open-source software which enables XnView and related programs to load PostScript-based file formats (PS + EPS + AI) as well as PDF for display, printing, and conversion.

Ghostscript has to be downloaded and installed separately.


XnView Classic as well as the 32-bit editions of XnView MP, XnConvert, nConvert, and XnShell require Ghostscript 32-bit to be installed (even on 64-bit operating systems), while all 64-bit versions need Ghostscript 64-bit.

Users of XnView Classic who run into trouble getting AGPL Ghostscript v9 to work are advised to give AFPL Ghostscript v8 (gs854w32.exe) a try.




How to activate thumbnails for PostScript files in XnView's browser and shell extension:

XnView Classic
Tools → Options... → File List → File List → AI, PS, PDF files → Show item in view 'Thumbnails'
XnView MP
Tools → Settings... → File list → Custom filter → AI/PS/PDF → Show as Thumbnail
Options... → No thumbnail for EPS/PDF

By default, Ghostscript loads images with a resolution of 72 dots per inch (DPI). This value can be customized:

XnView Classic
Tools → Options... → Read/Write → Read → EPS/PS/AI/PDF
XnView MP
Viewer/Editor: File → Format settings... → Read → PS/PDF
Tools → Batch convert... → Settings → Load format settings... → PS/PDF
Settings → Load format settings... → PS/PDF