Setting Up XnView

From XnView Wiki
Jump to: navigation, search

Setting Up

Setting up XnView on a computer is very simple and can be done by just copying the appropriate files onto your computer. This is basically what happens when you use the setup program.

During installation XnView does only two things: it creates a program group called XnView in Start > Programs, and it creates shortcuts on your desktop and in the task bar. There aren't any other registry settings made during installation. By default, options are stored in a .ini file, so Windows Registry will not be used and changed. For more information about how and where XnView's settings are kept, see the discussion on Settings and Ini Files.

After installing XnView, you should be able to start and use XnView without any problems. However, taking a few minutes to tailor XnView to your particular needs and preferences can make working with much easier, more pleasant and more effective.

The following sections give you some basic tips on how to set up XnView. As you will see, there are numerous choices available in the options dialog. Once you have worked a bit more with XnView, you should reopen the "Options" dialog and see whether you can do some fine tuning.

Using the Options Menu

All settings are available in the Options dialog of XnView. The settings are stored in the file "xnview.ini" or in the Windows registry. To open the option dialog, select the menu entry Tools > Options, or click on the toolbar icon, or press function key F12.

On the left side of the options dialog you will see the category tree. There are many options available, so they have been categorized for easier access. On the right side, there are the options. By clicking on an specific entry in the category tree, you can switch between categories. Some categories have sub categories, you will see a [+], then. Click on the [+] and the subcategories will become visible.

Suggested Options

Following are some suggestions about how you might want to customize XnView for your preferences. These are the things that most users find useful/helpful.

Category "Language"

When starting XnView the very first time, it determines and adopts your computer's language setting. If you have an English Windows installed, for example, the on-screen language of XnView will be English.

In some cases, such as when installing additional languages using the language pack as Add-On, you might need to set the language manually. In the category "Language" of the options dialog, simply select the language you want XnView to display. When confirming your setting with the "OK" button the options dialog will close and the language will change immediately.

Category "System Integration"

Add "Browse with XnView" to context menu

In MS Explorer, you can right-click on a file or directory and thus open the so-called context menu. When setting this options, a menu item "Browse with XnView" will be added to the context menu of MS Explorer. When browsing directories using MS Explorer, you can then quickly switch to XnView by right-clicking onto a directory, and then choosing the menu item "Browse with XnView". You will see XnView starting and displaying the contents of the directory you have applied the action. Very convenient.

Associate slide file with XnView

XnView supports slide shows. You can setup a slide show and watch it. If you want to see the same slide show at a later stage, you can save the slide show in a .sld file. When setting this options, you can double-click on a .sld file in MS Explorer and start the XnView slide show immediately.

Add XnView’s icon to desktop Add XnView to "Programs" menu Add XnView to "Start" menu

Depending on the way you work and how often you want to use XnView, you might find it useful to have icons or menu entries to start XnView. Decide what's best for you, and execute these functions or not. Note that if you used the XnView setup for installing XnView, you will already have an entry in the "Programs" menu.

Category "Associations"

XnView is an excellent graphic viewer and also offers various functions and features for image manipulation and editing. If you want to always open your image files in XnView when double-clicking on an image file in MS Explorer, you can set this here. In the category "Associations", choose the file types which you want to associate with XnView. See the discussion on Associations for more information.

Category "Browser"

Show Desktop in folder tree

By default, the top node of the folder tree shown in the XnView browser is the node "My Computer". Instead, you may want to have the node "Desktop" as top node. "Desktop" as top node is standard of MS Explorer and allows you to directly browse your "Desktop" folder, network environment and your "My documents" folder.

Changing XnView's Appearance

XnView has many options that allow for adjusting it to the users needs, and those include options to set and change the look of XnView. Here are some preliminary things you can do:

Function Shortcut
Set toolbar skin Go to Tools > Options > Toolbar > Skins and select a skin that you like.
Set XP menu style Check or uncheck Use XP style menus option on the Tools > Options > General > Startup menu.
Change layout The appearance of XnView's browser window is controlled by the View> Layout menu. See the discussion on Browser Mode.