Difference between revisions of "Browser Mode"

From XnView Wiki
Jump to: navigation, search
 
(One intermediate revision by the same user not shown)
Line 3: Line 3:
 
The browser mode window consists of three panes: navigation, thumbnails, and image. The layout of the browser mode window, the size of the thumbnails, and various other display options are controlled by settings (a) on the View menu, and (b) in ''Tools > Options > Browser > Thumbnails''. The relative size of the different panes may be adjusted with the usual Windows controls. You should experiment with these options and settings to find the browser mode display that is most effective for your particular needs.
 
The browser mode window consists of three panes: navigation, thumbnails, and image. The layout of the browser mode window, the size of the thumbnails, and various other display options are controlled by settings (a) on the View menu, and (b) in ''Tools > Options > Browser > Thumbnails''. The relative size of the different panes may be adjusted with the usual Windows controls. You should experiment with these options and settings to find the browser mode display that is most effective for your particular needs.
  
XnView's shortcut keys are context-sensitive. For the shortcut keys that work in Browser mode, see Browser Mode Shortcut Keys and All Modes Shortcut Keys.
+
XnView's shortcut keys are context-sensitive. For the shortcut keys that work in Browser mode, see [[Browser Mode Shortcut Keys]] and [[All Modes Shortcut Keys]].
 
[[File:Browser mode.png]]
 
[[File:Browser mode.png]]
  
Line 51: Line 51:
  
 
You can change the browser to your own preferences by adjusting the layout, sorting the images, layout and visibility of the panes and column visibility etc, by changing the browser settings using the Menu View.
 
You can change the browser to your own preferences by adjusting the layout, sorting the images, layout and visibility of the panes and column visibility etc, by changing the browser settings using the Menu View.
 +
 +
[[Category:Help/XnView|Categories]]

Latest revision as of 17:39, 27 April 2010

By default, XnView opens in browser mode. This is also the mode from which you will probably do most of your work and navigating with XnView.

The browser mode window consists of three panes: navigation, thumbnails, and image. The layout of the browser mode window, the size of the thumbnails, and various other display options are controlled by settings (a) on the View menu, and (b) in Tools > Options > Browser > Thumbnails. The relative size of the different panes may be adjusted with the usual Windows controls. You should experiment with these options and settings to find the browser mode display that is most effective for your particular needs.

XnView's shortcut keys are context-sensitive. For the shortcut keys that work in Browser mode, see Browser Mode Shortcut Keys and All Modes Shortcut Keys. Browser mode.png


Using The Browser

The XnView Browser is very similar to the Windows Explorer ®. The Browser window consists of three parts, also named panes:

  • The tree pane (tree view of directories, favorites view & categories view) on the left
  • The image files in the current directory on the right.
  • A preview of the selected image at the bottom, and information about it

You can open or select the Browser using the menu item File > Browser or the folder button in the tool bar. The Browser window can only be opened once (i.e. you cannot have multiple Browser windows)

The Browser opens in the last directory opened. You can change drives or directories by clicking in the directory tree on the left. When a directory has a small plus on the left, this means it has a sub-directory which can be opened by clicking on the plus symbol or double clicking on the directory symbol.

The current or selected directory is highlighted (normally in blue or grey) and any image files in this directory are displayed as thumbnails in the right pane of the browser window. You can perform the following actions with an image file:

  • An image is selected by a mouse click. In the lower pane of browser, the preview is displayed. In the status bar the most important information about the image is displayed.
  • An image is opened by a double click.
  • If the mouse pointer stays over an thumbnail (file), then a tooltip is displayed with image information e.g. colour density, size.
  • Double clicking on non images files will open them with their associated program, e.g. double clicking a Microsoft Word file will open the document using Word in a new window.
  • By Dragging & Dropping an image onto another application like Microsoft Word it can be edited in that application.
  • Clicking the right mouse button will open a context menu with functions which will be performed on the current selection.

The size of the three browser panes (Directory Tree, list of files, preview) adjusts to the to the size of the Browser window. You can also manually change the size of each pane.


How To Change the Size of the Browser panes:

  • Move the mouse pointer on the grey separating line between two panes. The mouse pointer changes to a File:Example.jpg or File:Example.jpg depending on the line chosen.
  • The separating line can then be dragged and changed as required by simultaneously keeping the left mouse button pressed and moving the mouse.


How To change the Display Type of Image Files:

The Menu option View > View As or the view symbol in the toolbar lets you change between different display styles for the image files:

  • Thumbnails - Images are displayed in miniature or thumbnails. This option is suitable in most cases. The size of the thumbnails can be changed as required by using the option View > Thumbnails Size ....
  • Thumbnails & Labels - Like Thumbnails but with labels (can be configured in option Thumbnails > Thumbnail Label).
  • Thumbnails & Details
  • Icons - Files are displayed as large symbols.
  • Details - Files are displayed as lists displaying names, size and other file information.
  • List - Only the file names of the files are displayed in a list, which is made up of several columns. This view is displayed very quickly, since the file information, but not the image data is read.

You can change the browser to your own preferences by adjusting the layout, sorting the images, layout and visibility of the panes and column visibility etc, by changing the browser settings using the Menu View.